We want to bring to your attention an urgent issue. A critical bug has been detected in the EJBCA and SignServer Software Appliance versions 2.3.3 and 2.4.0.
Issue:
The bug causes the logs to take up excessive disk space, leading to possible system performance issues and inhibiting the generation of support packages.
Cause:
This problem stems from the malfunctioning of syslog rotation due to incorrect compiler optimization in an external library (RSyslog) we use.
Solution & Next Steps:
We are set to release an updated version 2.4.1 on July 4, 2023, EOB CET, which addresses and rectifies this bug. We urge all users of the EJBCA Software Appliance to update their software as soon as the fix is available.
We sincerely apologize for any inconvenience this may have caused and assure you that we are doing everything in our power to rectify this issue swiftly.
If you need assistance or have questions, please contact our support team at support.keyfactor.com.